VS 2008 SP1 Team System Profiler + Hyper-V = BSOD

We recently joined the Microsoft BizSpark program. With that, comes access to the Visual Studio 2008 Team System versions. I decided to upgrade from VS Professional to the TS Developer Edition. I fired up one of our projects and started playing with the new features available to me. The code analysis part was neat. I expected more details and information, but I might just need to read up on what it’s telling me. Then I decided to fire up the Performance Wizard to see what that told me. Just as the app was about to start, boom. My first BSOD in Windows Server 2008.

The crash details:

IRQL_GT_ZERO_AT_SYSTEM_SERVICE
 
The computer has rebooted from a bugcheck. The bugcheck was:
0x0000004a (0x0000000077a55aea, 0×0000000000000001,
0×0000000000000000, 0xfffffa6008c7dca0)

After my box came back up I hit the Google to see if this was specific to my machine or a known issue. There weren’t a lot of hits, but I did get a few good ones.

  • This was first discovered as a known issue on the Intel Core i7 line
    of processors. A patch was released, and about half the people who
    posted something weren’t able to install it. My box is an AMD64 X2,
    so not a lot of help there.
  • This is the best report that I found. It matched what I saw exactly.
    http://social.msdn.microsoft.com/Forums/en-US/vstsprofiler/thread/03a058af-3832-4940-b00b-56ac911507dd
  • I then found a link to the Microsoft Connect site. It described the
    exact type of system I am using with the same crashing. In the end,
    it was reproduced in VS 2008, and fixed in VS2010. The cause is
    listed as such from the report:

I wanted to inform you that we have been able to reproduce the crash
you have experienced. The crash occurs on the specified processor when
Hyper-V is enabled on the BIOS and Hyper-V role is added to Windows
2008 Server.

We are working towards a solution. I will be in contact with you once
a solution is available. Thank you, once again, for taking the time
and bringing the issue to our attention.

Regards,
Daryush Laqab

Program Manager
VSTS Profiler, Code Coverage, and Test Impact Analysis


Posted by Microsoft on 3/19/2009 at 9:03 AM



Source: https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=418025&wa=wsignin1.0

There isn’t a post about the hotfix being released yet. I’ll take it as good news that there should be one on the way. I just hope we get it before VS 2010 ships.

Share this: